Brauche Hilfe um zu Verstehen....

  • Hallo zusammen,


    mein Name ist Thomas und ich bin neu hier. Ich habe mir den Axigen Server in der Version 10 installiert und er läuft jetzt auch erstmal soweit. Nun möchte ich Konten hinzufügen und bin jetzt etwas ratlos wie genau ich folgendes Szenario hinbekomme.

    Ich habe bei meinem Hoster die MX Records auf meine Adresse nach Hause geleitet. Da es sich um deine Dynamische IP handelt muss ich einen Umweg über myFritz gehen. Das funktioniert für meinen Webserver auch ganz gut. Was ich nun möchte ist folgendes:

    Axigen so einrichten das er für das senden der Emails den Hoster Server nimmt, dieser hat eine Feste IP und sollte somit auf keiner Blockliste stehen. Der Empfang sollte direkt in Axigen erfolgen. Des Weiteren habe ich noch folgende Frage: Ich benötige 5 Accounts. Wie bringe ich Axigen dazu den Webserver des Hosters zu benutzen und das jeder seine Richtige Absenderadresse hat? Hoffe ihr versteht was ich meine...


    Alternative wäre die RPOP Veriante. Gäbe es auch die Möglichkeit per IMAP auf die Konten zuzugreifen? Also bei POP wird die Email ja abgeholt. Schön wäre es, das ganze per IMAP zu machen.


    Grüße Thomas

  • Für den Versand über einen externen Provider, muss ein Smarthost in AXIGEN hinterlegt werden:

    https://www.axigen.com/knowled…-an-Axigen-server_93.html


    Hierbei wird nicht ein Konto pro User, sondern ein gemeinsames, Smarthost-Konto hinterlegt. Man authentifiziert sich bspw. über info@domain.tld, versendet jedoch über peter.mustermann@domain.tld .


    Beim Empfang reicht es, wenn Sie die Konten in AXIGEN anlegen und die MX-Records auf AXIGEN zeigen (auf Ihre DynDNS-Adresse, Port 25).

  • Hallo und Danke für Ihren Support,


    Sie schreiben

    Zitat

    Hierbei wird nicht ein Konto pro User, sondern ein gemeinsames, Smarthost-Konto hinterlegt. Man authentifiziert sich bspw. über info@domain.tld, versendet jedoch über peter.mustermann@domain.tld .

    das ist genau das, was ich nicht verstehe? Beispiel: Ich lege als im WebAdmin bei Smarthost die Adresse des Servers ein und hinterlege bei diesem die Zugangsdaten für info@domain.tld. Dann logge ich mich im Webmail als peter.mustermann ein und schreibe eine Email an blabla@irgendwas.de. Was sieht blabla@irgendwas als Sender? Sieht er peter.mustermann@domain.tld oder info@domain.tld?


    Warum muss der MX Record auf Port 25 zeigen und nicht z.B. auf 995?


    Gestern habe ich Versucht per RPOP externe 1&1 Konten zu integrieren. Leider ging dies nicht. Ich bekam eine Fehlermeldung das die empfangenen Nachrichten nicht gespeichert werden konnten und Status 2


    Update: Es kommt vereinzelt mal eine Email rein. Allerdings steht immer "Es wurde noch keine Verbindung hergestellt". Was kann das sein?

  • Der Empfänger sieht dann die peter.mustermann Adresse als Absender. Das ist die Definition eines Smarthosts. Man meldet sich mit einem Konto an, kann aber andere Absender verwenden (idealerweise nur aus derselben Domain). Die Frage ist, ob Ihr Provider das erlaubt, aber ich gehe davon aus.


    Port 25 ist laut RFC 5321 der Standard-Port für MX-Einträge. Ob SSL verwendet wird, oder nicht wird dann extra geregelt. Port 25 ist das Minimum.


    Zu RPOP: Was sagt das Log?

  • Code
    1. 2017-11-03 19:26:05 +0100 04 APHRODITE RPOP:000014F4: error delivering RPOP mail (Error connecting); will retry later
    2. 2017-11-03 19:26:05 +0100 04 APHRODITE RPOP:000014F4: remove RPOP mail enqueued with id 2219E1
    3. 2017-11-03 19:26:05 +0100 16 APHRODITE RPOP:000014F4: >> UIDL 987
    4. 2017-11-03 19:26:05 +0100 16 APHRODITE RPOP:000014F4: << +OK 987 0Lv55a-1bQ6gs3Aig-010JsT
    5. 2017-11-03 19:26:05 +0100 16 APHRODITE RPOP:000014F4: >> RETR 987
    6. 2017-11-03 19:26:05 +0100 16 APHRODITE RPOP:000014F4: << +OK

    Ich habe ein GMail Konto eingerichtet. Dieses funktioniert nur sporadisch. Es kommen zwar Emails, jedoch nur vereinzelt über Stunden.

    Die 1&1 kommen gar nicht...


    Code
    1. 2017-11-03 19:25:59 +0100 04 APHRODITE RPOP:000014F4: error delivering RPOP mail (Error connecting); will retry later
    2. 2017-11-03 19:25:59 +0100 04 APHRODITE RPOP:000014F4: remove RPOP mail enqueued with id 0CF20B
    3. 2017-11-03 19:25:59 +0100 16 APHRODITE RPOP:000014F4: >> UIDL 985
    4. 2017-11-03 19:25:59 +0100 16 APHRODITE RPOP:000014F4: << +OK 985 0M1lwh-1bVqyj0xOE-00tjQI
    5. 2017-11-03 19:25:59 +0100 16 APHRODITE RPOP:000014F4: >> RETR 985
    6. 2017-11-03 19:25:59 +0100 16 APHRODITE RPOP:000014F4: << +OK
    Code
    1. 2017-11-03 19:25:48 +0100 04 APHRODITE RPOP:000014F4: error delivering RPOP mail (Error connecting); will retry later
    2. 2017-11-03 19:25:48 +0100 04 APHRODITE RPOP:000014F4: remove RPOP mail enqueued with id 1F8B1E
    3. 2017-11-03 19:25:48 +0100 16 APHRODITE RPOP:000014F4: >> UIDL 984
    4. 2017-11-03 19:25:48 +0100 16 APHRODITE RPOP:000014F4: << +OK 984 0MM2N2-1bHqrq1HWW-007kxK
    5. 2017-11-03 19:25:48 +0100 16 APHRODITE RPOP:000014F4: >> RETR 984
    6. 2017-11-03 19:25:48 +0100 16 APHRODITE RPOP:000014F4: << +OK
  • Habe wohl das Problem gefunden. Zumindest bezüglich 1&1. Ich habe ClamAV (Glaube nicht das es daran lag) und Spamassis deaktiviert und nun flutschen alle Mails rein :)


    Dachte aber das ClamAV und Spamassis auf RPOP eh nicht funktionieren....


    Google Mail geht noch immer nicht.

  • Ok,


    Google läuft auch soweit. Jetzt sind zwar alle Nachrichten doppelt, aber egal soweit. Das mit dem Versenden klappt soweit auch :)

    Ich hätte jetzt noch gerne mein eigenes Zertifikat anstelle des axigen_cert.pem. Leider nimmt Axigen mein *.pem (Mit Sophos XG erstellt) nicht an und sagt, dass das Zertifikate invalid ist. Braucht es da was bestimmtes?

  • Sehr gut...

    Sie benötigen ein .pem File, dieses besteht aus dem private key und dem Zertifikat. Untereinander kopiert:


    -----BEGIN RSA PRIVATE KEY-----

    ...


    -----END RSA PRIVATE KEY-----


    -----BEGIN CERTIFICATE-----


    MIIGjTCCBXWgAwIBAgIPJ5wkodIVLwpTNi2vQDthMA0GCSqGSIb3DQEBCwUAMGUx


    ...


    -----END CERTIFICATE-----


  • Hallo,


    genauso weit war ich schon. Habe eine Anleitung gefunden gehabt, jedoch hat es nicht geklappt. Immer noch der gleiche Fehler. Habe allerdings beide Inhalte der Dateien unter Windows im Editor kopiert und dann als *.pem gespeichert und diese dann versucht zu importieren.

  • Hallo,


    bin jetzt weiter gekommen. Ich habe das Zertifikat nochmal neu erstell und dann in Sublime Text Editor zusammen geführt. Nun geht es :)


    Eine (hoffentlich) letzte Frage: Ich habe nun fast alles am laufen. Beim einrichten von DAVDroid und Axigen Tasks ist mir aufgefallen das zwar die Aufgaben Synchronisiert werden, jedoch nur wenn diese nicht in Unterordner liegen. Ich habe vorher Nextcloud DAVDroid benutzt und hatte den Sync auch mit Unterordner. In Axigen habe ich noch keine Option gefunden dies umzusetzten. Oder geht das gar nicht?