Aliase und Relay-Host (Smarthost)

  • Hallo, axigen läuft auf ubuntu 64bit. Interner E-Mail-Versand in meiner Domain klappt prima. Webmail gefällt mir - alles bestens!


    Ich würde jetzt gerne auch "rausmailen" mit einem smarthost (z.B. gmx-relay) und meiner GMX-Adresse als Absender, damit replays wieder an die GMX-Adresse kommen.
    Muss ich da einen Alias mit meiner GMX-Adresse anlegen, wenn ja, dann hat der Alias ja immer noch meine Domain im LAN zu Hause und nicht "gmx.de"
    Muss ich "mail.gmx.net" als smarthost angeben oder nur eine Regel erstellen, wie ich das in einem Posting gelesen habe.


    Fragen über Fragen^^ Sry, ich kenn mich im Mom gar nicht mehr aus! :confused: :o

  • Hallo, vielen Dank für die schnelle Antwort, ich bin beeindruckt, wie gut hier der support ist!!! gz!


    Ich habe die Modifikationen wie im HowTo beschrieben ausgeführt, jetzt lässt sich allerdings der Mail-Server nicht mehr starten :confused:
    Ich poste hier mal meine smtpFilters.script:


    Die Datei gehört dem User und der Grp axigen.


    Warum lässt sich axigen nicht mehr starten?


    Hinweis: Als ich im AXIGEN WebAdmin den Smarthost eingetragen habe, ließ sich der Server starten. Nach den Erweiterungen in der smtpFilters.script nicht mehr!


  •  
    Hier liegt wohl der Fehler... In dieser Klammer (oben rot marktiert) - richtig wäre laut Beispiel:
     

  • Hallo, nein die Mail geht weder raus noch kommt sie zurück.


    Wenn ich im WebAdmin übrigens auf Acceptance & Routing gehe, erhalte ich die Meldung "Error parsing SMTP filters file Do you want to overwrite the SMTP filters file?" und kann auf den Button "Override" klicken. Kommt das aufgrund der manuellen Änderung der Datei smtpFilters?


    Hier mal die Logdatei "everything.txt" und daraus der Bereich der Webmail-Session:


    Ich hoffe, Sie blicken durch^^
    Vielen Dank für Ihre ausdauernde Bemühungen!
    09-23 15:06:13 +0200 08 server SMTP-OUT:0000000A: Relay mail 33D7D3: no more relays for gmx.de

  • Hier mal noch der Code, der beim Einloggen ins Webadmin abgelegt wird:


    Teil 2 folgt...

  • Teil 2:


    [/FONT]

  • Durch die Modifikation der smtpfilters dürfen Sie die händisch angelegte Regel im Webadmin nicht mehr ändern.
     
    - Deaktivieren Sie alle Filter (die finden bei Smarthost und RPOP keine Anwendung)
     
    - Prüfen Sie Ihren Hostname
     
    hostname
    hostname --fqdn

  • hostname und hostname --fqdn ergeben beide das gleiche. Es wird der servername ausgegeben.


    Im Bereich "Security & Filtering" ist bei "Antivirus & Antispam" alles deaktiviert, bei "Additional Antispam Methods" und "Acceptance & Routing" komm ich gar nicht mehr rein, hier kommt die Meldung, die ich oben beschrieben habe.
    Soll ich hier mal auf "override" klicken?

  • Irgendetwas ist bei Ihrer Konfiguration faul - haben Sie nun den Smarthost eingetragen und nutzen diesen, oder nicht?
     
    09-23 15:11:15 +0200 08 server PROCESSING:0022DDBB: Filter SpamAssassin Filter(127.0.0.1:1987):[PASS]: Spam: False ; 2.2 / 5.0
     
    Der dürfe bei einer Verwendung des Smarthosts gar nicht anspringen.

  • Von alleine wird er sich nicht aktivieren...
     
    Sie versenden die Emails direkt über eine Dialup-IP und GMX weist Sie zurecht zurück. Sie haben wohl vergessen, den Smarthost zu aktivieren. Siehe Anhang.
     
    Die Mail müsste auch zurückgekommen sein - der Postmaster sollte benachrichtigt worden sein - oder sie hängt noch in der Queue.